Welcome, Guest
Username: Password: Remember me

TOPIC: mrskew: no match for file glob 'p10' in MRTOOLS_RC

mrskew: no match for file glob 'p10' in MRTOOLS_RC 1 year 10 months ago #361

I am trying to perform this command:

C:\\Documents and Settings\\nogal003\\mrtools>mrskew ngetst1_ora_29641_SFMD1.trc --name=read --rc=p10
mrskew: no match for file glob 'p10' in MRTOOLS_RCPATH (.)
CALL-NAME DURATION % CALLS MEAN MIN MAX
db file sequential read 8.551353 100.0% 1,021 0.008375 0.000260 0.046036
TOTAL (1) 8.551353 100.0% 1,021 0.008375 0.000260 0.046036


I don't have any rc file called p10. Do I need to create one? I want to check the skew in the read call latencies.
The administrator has disabled public write access.

Re:mrskew: no match for file glob 'p10' in MRTOOLS_RC 1 year 10 months ago #362

The p10 file is shipped with MRTools in the folder bin/rc/. To take advantage of these, set the environment variable MRTOOLS_RCPATH to the full path of that folder.

You can find more about this variable and the rc files in the help, accessible with the command

mrskew --man

Or see the documentation online.
Last Edit: 1 year 10 months ago by Ron Crisco.
The administrator has disabled public write access.

Re:mrskew: no match for file glob 'p10' in MRTOOLS_RC 1 year 10 months ago #363

Brilliant! Thanks Ron!
The administrator has disabled public write access.

Re:mrskew: no match for file glob 'p10' in MRTOOLS_RC 3 months 5 days ago #442

Hi Ron,

My DOS command prompt doesn't properly display some characters while using this rc p10 e.g. alpha (infinity), le (less than or equal). Not sure what goes wrong.
RANGE {min โ‰ค e < max}    DURATION       %   CALLS      MEAN       MIN       MAX
-----------------------------  ----------  ------  ------  --------  --------  --------
 1.     0.000000     0.000001
 2.     0.000001     0.000010
 3.     0.000010     0.000100
 4.     0.000100     0.001000    4.019849    2.9%   5,070  0.000793  0.000213  0.000999
 5.     0.001000     0.010000   58.050824   41.2%  18,759  0.003095  0.001000  0.009994
 6.     0.010000     0.100000   69.121696   49.0%   2,883  0.023976  0.010000  0.099471
 7.     0.100000     1.000000    9.778449    6.9%      42  0.232820  0.103291  0.706208
 8.     1.000000    10.000000
 9.    10.000000   100.000000
10.   100.000000 1,000.000000
11. 1,000.000000           +โˆž
-----------------------------  ----------  ------  ------  --------  --------  --------
                   TOTAL (11)  140.970818  100.0%  26,754  0.005269  0.000213  0.706208
The administrator has disabled public write access.

Re:mrskew: no match for file glob 'p10' in MRTOOLS_RC 3 months 5 days ago #443

Bundit,

To fix this, just edit the file In your rc directory. At the top of each file, you'll see a comment on the order of "Each line containing a Unicode character below is followed by an equivalent line, commented out, which contains an equivalent ASCII representation..."

For the p10 file, it's an easy edit: there are, as you've noticed, two Unicode characters that DOS cannot display. I think you'll find those on lines 22 and 45. While you're in your rc directory, I'd encourage you to look at the other files, too, for opportunities to make the same edit.

We have experimented with the chcp command on DOS (e.g., 'chcp 65001') to see if we can get DOS to render proper multibyte Unicode characters. In the past, we tried but didn't figure it out. Jeff and I will give it another try. I'll let you know if it works for us...


Cary Millsap
The administrator has disabled public write access.
The following user(s) said Thank You: Bunditj

mrskew: no match for file glob 'p10' in MRTOOLS_RC 3 months 5 days ago #445

  • Jeff Holt
  • Jeff Holt's Avatar
  • OFFLINE
  • Posts: 107
  • Thank you received: 2
I was able to make it work without editing the rc files.

I changed my command shell font to Lucida Console and then executed this command before executing the mrtools commands:

chcp 65001

I found this solution at stackoverflow.com/questions/388490/unico...ows-command-line-how
The administrator has disabled public write access.
The following user(s) said Thank You: Bunditj