Welcome, Guest
Username: Password: Remember me

TOPIC: How to enable logging in SQL Developer

How to enable logging in SQL Developer 2 years 7 months ago #293

  • hpalacio
  • hpalacio's Avatar
When trouble shooting MR Trace it's necessary to collect the log messages. However, the default configuration for SQL Developer does not enable the "Logging Page" panel.

The logging panel can be enabled with the following steps:

1) Close SQL Developer, and open the following file for editing
{sqldeveloper installation path}/sqldeveloper/bin/sqldeveloper.conf

2) comment out the line containing "sqldeveloper-nondebug.conf" and add the following two lines (see attached image):

IncludeConfFile sqldeveloper-debug.conf
AddVMOption -Dcom.methodr.loglevel=all

3) save file, and restart SQL Developer. You should now see a "Logging Page" tab as shown in second attached image.
Attachments:
Last Edit: 2 years 7 months ago by hpalacio.
The administrator has disabled public write access.

Re:How to enable logging in SQL Developer 2 years 7 months ago #295

  • hpalacio
  • hpalacio's Avatar
editing the config file...
Attachments:
Last Edit: 2 years 7 months ago by hpalacio.
The administrator has disabled public write access.

Re:How to enable logging in SQL Developer 2 years 7 months ago #296

  • hpalacio
  • hpalacio's Avatar
location of the "Logging Page" tab...
Attachments:
The administrator has disabled public write access.

Re:How to enable logging in SQL Developer 2 years 7 months ago #297

I have never tried it. Anyone?
The administrator has disabled public write access.

Re:How to enable logging in SQL Developer 2 years 7 months ago #298

JamesLewis wrote:
I have never tried it. Anyone?
Yes, I have - it works as described.

However, on Windows the path to the BIN directory is a little different. On my machine is it <installation path>/sqldeveloper/sqldeveloper/bin/


--jimmy
The administrator has disabled public write access.

Re:How to enable logging in SQL Developer 2 years 7 months ago #300

JamesLewis wrote:
I have never tried it. Anyone?

Yup, I have tried it, it works properly as suggested by hpalacio.
The administrator has disabled public write access.